Issues with file uploads
Incident Report for PowerSchool Learning
Resolved
We have resolved the issue and expect that all file uploads are now working smoothly. Thank you for your patience!
Posted 2 months ago. Oct 11, 2017 - 18:26 PDT
Investigating
We are currently investigating errors when uploading files. We are working to resolve as quickly as possible. So sorry for the inconvenience!
Posted 2 months ago. Oct 11, 2017 - 17:06 PDT