Issues with file uploads
Incident Report for PowerSchool Learning
Resolved
We have resolved the issue and file uploads are now working successfully. Thank you for your patience!
Posted 2 months ago. Oct 12, 2017 - 10:01 PDT
Investigating
We are investigating intermittent issues with file uploads. Our team is working quickly to resolve.
Posted 2 months ago. Oct 12, 2017 - 07:24 PDT