Intermittent login errors in PowerSchool Learning
Incident Report for PowerSchool Learning
Resolved
The performance issue affecting some PowerSchool Learning customers has been resolved. The authentication process should now function as expected. Thank you for your patience!
Posted 24 days ago. Mar 26, 2018 - 12:47 PDT
Investigating
We are aware that some Learning customers may currently be experiencing errors upon login. We apologize for the inconvenience this may have caused and we are working diligently to restore full system functionality. We will provide updates as they become available. Thanks for your patience!
Posted 25 days ago. Mar 26, 2018 - 09:15 PDT