Issues saving content in PowerSchool Learning
Incident Report for PowerSchool Learning
Resolved
We have resolved the issue with updates not saving in PowerSchool Learning, and expect that all Save actions are now successful. If multiple attempts to create/save an item were made, all attempts should now resolve and duplicates can be manually deleted as necessary.

Thank you so much for your patience as we worked through this!
Posted 4 months ago. Jul 29, 2017 - 10:10 PDT
Investigating
We have identified issues saving various types of content across Powerschool Learning. Updates to Pages, Blocks, Discussion posts, Imports, Grades, etc. may not save at this time. We apologize for the inconvenience, and are working quickly with our team to resolve this.
Posted 4 months ago. Jul 29, 2017 - 08:44 PDT