Investigating errors and access issues
Incident Report for PowerSchool Learning
Resolved
We have resolved the issue and access is restored. Errors are no longer expected at this time, and our team will continue to monitor. Please let us know if you run into any further trouble!
Posted 3 months ago. Sep 01, 2017 - 09:08 PDT
Investigating
We're currently investigating reports of slowness and 500 errors when accessing PowerSchool Learning. We're working hard to resolve this as quickly as possible. Our apologies for the inconvenience!
Posted 3 months ago. Sep 01, 2017 - 07:21 PDT