Lag in item creation
Incident Report for PowerSchool Learning
Resolved
We have resolved this incident and are monitoring closely.
Posted 9 months ago. Dec 12, 2017 - 12:29 PST
Investigating
We are experiencing a slight lag the processing of actions such as creating a new Assignment and entering a grade. Our team is working quickly to address. Thank you for your patience!
Posted 9 months ago. Dec 12, 2017 - 07:36 PST