Intermittent disruption when launching from Google Marketplace App
Incident Report for PowerSchool Learning
Resolved
PowerSchool Learning experienced an intermittent service disruption when launching PowerSchool Learning from the Google Marketplace App. We apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve these issues. We strive to provide the best possible experience to our customers. Please don’t hesitate to contact PowerSchool Support with any questions.
Posted 2 months ago. Mar 14, 2019 - 12:31 PDT
Investigating
We are aware that some customers using PowerSchool Learning are experiencing a disruption when launching PowerSchool Learning from the Google Marketplace App. Users are still able to login, as normal, via the URL for their School .learning.powerschool.com. We apologize for the inconvenience this may have caused and we will provide updates as they become available.
Posted 2 months ago. Mar 14, 2019 - 10:48 PDT
This incident affected: PowerSchool Learning.