Investigating issues with Google SSO
Incident Report for PowerSchool Learning
Resolved
We have resolved the issue with Google SSO, and expect all access to Learning to be restored. Thank you!
Posted 10 months ago. Feb 13, 2018 - 10:52 PST
Investigating
We are aware of intermittent errors when accessing Learning via Google SSO. Our team is actively investigating. Thank you for your patience!
Posted 10 months ago. Feb 13, 2018 - 10:04 PST