PowerSchool Learning Intermittent Service Disruption
Incident Report for PowerSchool Learning
Resolved
PowerSchool Learning experienced a service disruption today at 6:55am PST that caused a service disruption. We worked diligently and services were restored at 8:41am PST. We apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve these issues. We strive to provide the best possible experience to our customers. Please don’t hesitate to contact PowerSchool Support with any questions.
Posted 7 months ago. Apr 02, 2019 - 09:08 PDT
Investigating
We are aware that some customers using PowerSchool Learning are experiencing a service interruption. We apologize for the inconvenience this may have caused and we are working diligently to restore full system functionality. We will provide updates as they become available.
Posted 7 months ago. Apr 02, 2019 - 07:54 PDT
This incident affected: PowerSchool Learning.