PowerSchool Learning Service Interruption
Incident Report for PowerSchool Learning
Resolved
PowerSchool Learning experienced a service disruption today at 8:25am PST that caused files being uploaded to stay in a processing state. We worked diligently and services were restored at 9:25am PST. We apologize for any inconvenience this may have caused and appreciate your patience while we worked to resolve these issues. We strive to provide the best possible experience to our customers. Please don’t hesitate to contact PowerSchool Support with any questions.
Posted 5 months ago. Mar 05, 2019 - 09:34 PST
Investigating
We are aware that some customers using PowerSchool Learning are experiencing a service interruption. We apologize for the inconvenience this may have caused and we are working diligently to restore full system functionality. We will provide updates as they become available.
Posted 5 months ago. Mar 05, 2019 - 08:37 PST
This incident affected: PowerSchool Learning.